Hi, apologies if this has been asked before, I tried to search for "password", "form", "oauth" etc and wasn't getting anywhere.

I'm running a docker-compose stack with sonarr, radarr, sabnzbd etc. Both sonarr and radarr I'm running the v3 betas. The services are reverse proxied with traefik and pointed at my domain name.

With no auth I can access sonarr with nzb360 at https://sonarr.mydomain.com no problem

With basic auth I can access it at https://username:password@sonarr.mydomain.com

However with auth set to Form/Login Page I can't access it at all. Is this a problem/limitation with nzb360 or sonarr/radarr? Is there any way around it or a roadmap to have it added soon? The basic/browser popup method is a bit of a pain because I can't fill the dialogue box with Bitwarden in a desktop browser.

On the same topic, can nzb360 be configured to work with either of OAuth or Authelia for SSO? If so that would mean I can skip the user:pass in the URL.

i found my problem. In connection address I left a "/" at the end of the address. It worked in basic authentication but not in in auth set to forms login page ...
a +
modem7 wrote:
Sat Nov 21, 2020 6:16 pm
I've got it working with authelia in docker w/ API key oauth bypass. Do you want my config?
Would you mind posting that? I'm trying to get this working for me.