So just to clarify; if i install nzb360 v10.8.3 everything works great and NZBGet works fantastic.

But somewhere after that (version) the URL/configuration string for NZBGet was broken and no longer works.

v10.8.3 is starting to get old now and I'm missing out on some of your new features you got. Hence i just thought i'd shed light o this in hopes it's a simple fix.

The working NZBGet URL (in v10.8.3) is:
https://user:password@domain/nzbget/- The user:pass is for the http authentication in place.
Then the NZBGet Username and NZBGet Password are left blank because i don't have one; but i tried populating these too without any success.

I also tried different variations of the user/pass by just setting to domain to https://domain/nzbget/ and putting the user/pass combo in the entries below without any luck either.

The error message i get back using the newer versions of nzb360 when I press 'Test Connection' is: "Failed to connect to primary address Try again?"

From my end of things, my configuration isn't changing; just your amazing app is being upgraded. On my end I Just have a hostname with a bunch of /paths each mapping to different apps (Sonarr, CouchPotato, etc). I have some password protection on the NGinx server that serves this data as a proxy.

Any advice you have would be awesome! :)
Yeah, v10.9 changed the way I handled settings and connected to services. The underlying code to connect didn't change much, but they way it was entered into the UI did quite a bit. If you PMd me your NZBget connection details I could debug and figure out the right way of entering them in for your setup post v10.9.
Did you get a solution for this? I too am having trouble with NZBGet only via reverse proxy, am able to access via web interface both locally and remote but, can't get it working from within NZB360.
jimbo123 wrote:
Sun Feb 24, 2019 3:34 pm
Did you get a solution for this?
No not yet :), but it's good to know i'm not the only one.

Kev, did you make this change to accommodate someone else (and their request)? Or was the goal of the change )that broke it for us) to simplify something else? I'd love if you just rolled back the whole http configuration change as it once was. ;)
It's been almost 6 months since i posted and hadn't heard back. I just wanted to provide a bit more perspective on the problem here. I did email you your own private login details months ago to test with; it's still running if you need to use it. It's possible it just got lost in all of your other requests :).

It's also worth noting that the SAME (Primary Connection) URL works great with all other services such as Sonarr, CouchPotato, etc. The only thing that changes is the ending URL path. On my end, everything is tied behind the same NGinX configuration with basic auth in place. NZBGet is the only NZB360 Service that does not work.

It's also worth noting that since i rely on NGinX's configuration, I do not have a username and password set up to NZBGet at all. I'm connecting to all Services using the standard: https://nginx_auth:nginx_pw@myserver/path/to/service

Here is a screenshot showing the connection failure for NZBGet only (upon using the Test Connection button) when all Primary Connection Addresses are exactly the same (except trailing portion of URL). v10.8.3 however connects in all cases. Image Unfortunately due to the newer Android Operating system, i can't install the old working version any more :(

For consistency sakes, shouldn't the Primary Connection Address associated with NZBGet behave the same as every other supported API/Service?
To be fair, in our email exchanges, you also figured out that you can't have a trailing slash in the NZBGet URL (which i had) or the service doesn't work either. ;)

So the take away is:
  • NZB360 Primary Connection Address (PCA) URLs only takes hostname and path to NZBGet.
  • No trailing slashes in PCA URL or it will NOT work.
  • Nginx user/pass goes in fields labelled NZBGet User/Password.
Regardless.. thank you so much for all your help tonight. :) Seriously, very much appreciated! It's sooo nice getting this feature back again.

Perhaps as a small request for a future release: just take away reference to the schema://user:pass@domain in the on-screen documentation of the app (after you click on the Primary Connection Address field to change it)? This small change only needs to be done to the NZBGet/NZB360 Area, not the others.