#1
A week ago, I setup sabnzbd, sonarr, and radarr both locally and remote with reverse proxy. All three seemed to be working fine. Now, today all of a sudden, radarr and sonarr give an "error: null" response, but sabnzbd still works fine.

In a web browser, I can still access all three applications remotely and locally without issue. But on nzb360, only sabnzbd connects. Radarr/sonarr cannot connect locally or remotely.

How do I even begin to troubleshoot something as vague as "error:null" ? Nothing changed in sonarr/radarr with ports, settings, credentials, or APIs. Nothing shows up in the logs of sonarr/radarr. Nothing shows up in my web server logs for reverse proxy issues. And I don't see anywhere on the app that provides a log with more information.

Any ideas?
#2
Null is coming back from those services in terms of an error. This is usually because it cannot connect to the server instance. Is your API key correct?
#3
Kev wrote:Null is coming back from those services in terms of an error. This is usually because it cannot connect to the server instance. Is your API key correct?
Unless API keys somehow have the ability to modify themselves on their own, yes, the API key is correct. Nothing has been modified on the phone app or the services.

I double checked the API anyways and they're for correct.
#6
I need to add better logging, no doubt. Since you're using reverse proxies, my bet is how you entered in the details into nzb360. Can you send me a PM with your settings page?
#7
Hey Kevin,

I've also been getting this error on sonarr recently when trying to add new episodes. "Error:null". I was just wondering if there was a fix for it yet? I have the correct API key and the host name and settings are correct. I'm able to load my sonarr just fine on chrome so that's all working fine. I even double checked my nzb get settings and that's all correct.
#9
Kev wrote:Are you on the development channel for updates?
I'm not now, but I'd be happy to switch if you need me to help test changes to the connectivity settings.

Sent from my SM-G950U using Tapatalk
cron