#1
Great app, have been a paying supporter for years. One of the only reasons I stick with Android.

However I've recently started using a reverse proxy and can't for the life of me get it working.

I've sent through an official support request with all my details but haven't received a response.

Any help would be great

Cheers
#2
How are you entering your port details? For reverse proxies, you probably want to type in 80/sonarr for example. (or 443 for ssl).
#3
Hi,

Yeah I've tried every combination. 80 with HTTP, and 443 with HTTPS.

Have also tried using subdomain and subdirectory, no luck.

I have a password set in Apache, no auth in the apps themselves, NZB360 doesn't accept the username and password.
#5
Kev wrote:Try setting your user/pass like this in the IP field: user:pass@host
Hi Kev

Have that also.

So this is what I have set up:

IP/Host: username:password@subdomain.host.net
Port: 443
SSL/HTTPS : Ticked

When entering in the host as above into a webbrowser, it still asks me to enter in a username:password via browser prompt. Could this be the issue?

When I type in the same username and password into the browser prompt, it then takes me to a secure HTTPS site.
#7
I recently went through the same dance but eventually got it working. If I'm being honest, the server settings field could probably be parsed out with a little more granularity to make this more straight forward. It took a significant amount of guessing and checking, but it did eventually work. Here's my settings:

IP/Host Address

Code: Select all

localip, user:password@domain.com
Be sure to include the space after the local ip address.

Server Port for [Program]

Code: Select all

LocalPort#, /url_base
This was the kicker for me (and why I feel like fields should be parsed out further). With a reverse proxy, you're not expressing a "remote port." You're expressing the subdirectory, which handles the remote port for you. So having them both listed in the example instructions can be confusing. In my case, my subdirectory is /sabnzbd and my internal port is 8080, so my exact input here is:

Code: Select all

8080, /sabnzbd
Note the space after the comma.

Hopefully that helps. It took me about a full hour of trial and error to figure that out. Where ever you see "remote port" just replace that phrase with "sub-directory"
#8
Thanks for the detailed response- much appreciated.

Unfortunately I still can't get NZB360 to detect my Sabnzbd, even with your instructions.

If I type the following into a browser, SAB loads:

user:pass@host/sabnzbd

However if I enter this same information into NZB360, it doesn't load:

IP/Host Address:
user:pass@host

Port:
/sabnzbd

Previously I was entering 443 into Port, that doesn't work either.

SSL is ticked

I think the problem lies in the fact that I can't manually type https:// in the host field- as a result, I have a HTTPS reroute that triggers another auth.
#9
Are you doing SSL through sabnznbd directly, or through your parent domain/web-server? If you're doing it through your web domain, then you should uncheck SSL, since that's for the sabnzbd setting.

"port" in this case would never be a number, since you're using a reverse proxy.
#10
SSL is managed by the domain/webserver.

Because I can't specify http or https in the host field- if I don't put port 80 or 443, or select SSL, how does the client know what port to connect to?
cron