#1
Hello,

I'm having trouble setting up my indexers. I'm running my own server which is downloading spots (SpotWeb).
Now, when I secure the indexer with a username and password, the app can't connect to the server saying "Error retrieving info from server.
When I remove the username and password from the indexer, the app can connect without any trouble.

I've tried several things to connect but there is no way to insert a username and password in the app for indexers, is there any other way to use this? (I've also tried to put 'https://' in front of the url yes :)).
#3
It's an integrated login form, on my computer I have to login with a username and password which is stored in the database on my server. The password is, ofcourse, MD5 protected.

I don't know if this is the problem why it can't connect to the 'protected' server, but I think this is the reason. Because there is no option to give an username and password with the indexer to authenticate.
#4
Hmm,the app currently doesn't support authentication for NN sites. You could post a feature request if you want it. That said, I've thought of a few ways to (possibly) bypass.

1. Find out if the server accepts the credentials through GET parameters. It's usually done via POST but it may accept GET nonetheless. e.g. http://site.com/index.html?user=admin&password=12345

You would have to find out the exact parameters though. You could use a proxy that will intercept the request like wireshark or Burp proxy. Look in the request, probably a POST, and use the exact same parameters and put them in the URL like I showed above.

2. Disable the integrated authentication. Apply basic authentication (.htaccess). Google it for tutorials. Then go to NZB360 settings, and enter the URL like so: username:password@https://site.com

I don't know for sure if this will work, but you can try it out.
cron