#2
Getting the same here, just started a few days ago. This isn't happening when I use the Couchpotato web interface and there's nothing in the CP logs either. Seems to be isolated to NZB360.

Dev, please feel free to contact me by email. I'm a software analyst by trade and happy to help however I can.
#3
I have this same issue. Also started a few days ago.

It seems like something has changed, either in Couchpotato or in IMDB (and the data that CP stores).

I'm also an ex software dev and happy to help. :-)

EDIT: I *may* have figured it out. Seems like CP changed the JSON API response in the rating.imdb section.

Old syntax:

Code: Select all

"imdb" : [7.9, 304909]
New syntax:

Code: Select all

"imdb" : {
	"0" : 5.5
}
It has only done this for new additions to the database. Old movies still seem to retain the old syntax.

Can anyone confirm this?
#4
skorov wrote:I have this same issue. Also started a few days ago.

It seems like something has changed, either in Couchpotato or in IMDB (and the data that CP stores).

I'm also an ex software dev and happy to help. :-)

EDIT: I *may* have figured it out. Seems like CP changed the JSON API response in the rating.imdb section.

Old syntax:

Code: Select all

"imdb" : [7.9, 304909]
New syntax:

Code: Select all

"imdb" : {
	"0" : 5.5
}
It has only done this for new additions to the database. Old movies still seem to retain the old syntax.

Can anyone confirm this?
I noticed this only for rating that are 0. There was a issue opened on gh and I mentioned there that it might be related. Have yet to hear from Kev or RuudBurger
#8
Just thought I would chime in that I have been getting the same error as well. I am on the master branch and no settings in NZB360 have been touched. it just started giving this error when a checked it a while back.
#10
Kev wrote:Issue has been resolved. Update coming shortly.
Yay! Just wanted to say thanks Kev! Not just for the fix, but also for a really great app. I use it almost daily. :-)