#1
First off - great app. It looks awesome and once I get it working I'm confident that I'll love it!

I can succesfully connect to SABnzbd locally and remotely but Sonarr won't work either way. I've got nMatrix working fine too.

When trying to access Sonarr, I get a http 400 - bad request, invalid hostname - error when trying via nzb360 app or accessing it from my phone's browser. I have not upgraded to pro - is this a pro feature?? I was hoping to get it all working before I commit to paying for the app.

So far I have done the following;
  • Double checked that my API key is correct in nzb360 settings
    Restarted the server & all services (ie; sonarr, sabnzbd, etc)
    Checked the IP address for my server (infinite DHCP lease given to it so it stays the same)
    Checked that port 8989 is forwarded
    Tried putting the server into the dmz but it made no difference
    Turned off all hardware & software firewalls just incase - then made a specific exception for Sonarr - no joy
Relevant Sonarr settings are as follows:
Bind address: *
Port number: 8989
URL Base: (empty)
SSL: off
Authentication: off
Updates: master
Version: 2.0.0.2663

I noticed when configuring sab, it wouldn't work because i forgot to add in the authentication details (user:pass@ip:port) but did not report any errors except that it couldn't connect. I have no authentication on Sonarr so not sure why it isn't working.

Does anyone have any ideas about what I can do to get this working? I've found it very difficult to find much information online about the configuration of this app. The guide in this forum is quite good but seems to omit a fair bit of information, such as setting Sabnzbd to use 0.0.0.0 instead of localhost. It would be good to have some 'guideline' settings for each service that the app can access, to help new users with their config. Generally I imagine it just works but if it doesn't, it's very hard to find information.
#2
Ok after some further googling, I realised that Sonarr must be run as Administrator in order to open ports properly. Now it's working fine! Hopefully this helps someone else?
cron