I honestly don't know why but I have never had this issue before all of a sudden I can no longer connect to sickbeard. It just says not connected to sickbeard server I tried reseting the api key I tried regarding sickbeard still no luck. I can access it just fine using a browser and my dyndns server but it just doesn't seem to want to work with the app.
When you say browser, do you mean the one on your laptop/pc or the one on the same device nzb360 us running on ?

Try looking for errors in sickbeard logs too.
When I said browser I meant on the same device, IE my galaxy note cant access sickbeard via nzb360 but using the same url in google chrome on the device that I use on nzb360 it accesses sickbeard just fine.

I also checked sickbeard and no error messages are popping up when I try to connect to it.
I think the connection needs to be tested. If you want you can PM me with connection settings and I can look if I can connect myself. You can create a new temporary ddns host and api key if you like.

Otherwise you will need to wait for a response from the developer (who might ask you for the same)