#11
Sorry to re-bump this! But i'm also having similar problems. Just upgraded to pro, well worth it btw, and I cant seem to make my NZBDrone work even though SABnzbd works. I dont use any SSL or HTTP Auth, just a plain old API key, port and host. I've tried all the solutions listed above but none have worked so far. I was wondering if maybe the problem was similar to the localhost vs 0.0.0.0 problem in SABnzbd?

Assistance would be appreciated very much! :D
#15
I just wanted to bump this -- I, too, can't seem to connect to nzbdrone. API key was confirmed, I've tried disabling authentication, but when I try to refresh my NzbDrone I get: "Error: null." Any ideas? I'm using NZB 360 v 8.5.5.
#17
It happened for me too. On both devices simultaneously (N5/Lollipop and Asus PadFone/Kitkat 4.4.4). All of a sudden, neither of my devices could connect to nzbdrone anymore, although I didn't change a single setting. Only thing I did was fillong the database with shows. To verify it's not my infrastructure causing the issues, I reseted everything (wiped the nzdrome home dir) and it worked again. I setup everything as it was before (port, authentication, ...) and everything was still fine. Than I started to fill scan my drive again, and all of the sudden, the very same error reappeared.

This is very unfortunate, as I really like the App (bought a pro account very recently which were also 10 bucks), but with this bug it's not usable. Can I provide any log/traces that helps you debug? Would very much like to use it again as my main app.

Cheers,
RAlph
#19
I just made the switch and getting this too. Sometimes "Error: ." and other times "Error: null". ip (local) is correct, so is port and api. ssl is off. Sonarr Ver. 2.0.0.2341