When trying to manually search (via NZBHydra2) and send downloads to NZBGet the downloads get stuck on "fetching" for about 5 seconds or so and then they fail. Every other app within nzb360 works perfectly fine, it's just the manual search connected to NZBHydra2 that doesn't.

When I disable HTTP authentication on nginx and NZBHydra2 everything works fine, so it seems as though this issue is authentication related. I read that you need to have your nginx and NZBHydra2 authentication setup the same (same username and password), which I did, but that didn't fix the issue.

I feel like I've tried every solution that I've been able to find online, however nothing has worked yet.

Does anyone have any idea how I would go about fixing this?
Did you ever find a solution to this? I seem to be having the same problem. I have NGINX reverse proxy that has been working for a long while with other NZB apps and NZBHydra on my phone but with NZB360 I get the same as you. If I try to download the NZB file using NZB360 the NZB file contains:-

Code: Select all

<head><title>401 Authorization Required</title></head>
<body bgcolor="white">
<center><h1>401 Authorization Required</h1></center>
I guess this is also what's being passed to SABnzbd and NZBGet causing them to fail.
To be honest I kind of forgot about this issue, but I just tried again and it's actually working now, so you may be having a different issue than I was.

Do you have HTTP authentication setup with both nginx and NZBHydra2? If so, do you have the same username and password set for both? If so, I'm not sure what might be causing this.
Yes, set up with both and both set to the same username/password. I've just been having a play now and it seems to be something with NGINX and NZB360. If I disable the authentication part for NZBHydra it seems to work fine. As soon as it's enabled it fails again when passing the file to SABNZBD/NZBGet. I'll have a play when I get more time.