#1
Hello,

I've previously set up my services (radarr/sonarr) to be accessible remotely via reverse proxy and that worked fine with NZB360.

I'm changing my setup around a bit, and adding server side auth via Organizr v2.

This means that you auth to radarr or sonarr automatically once you have authenticated into the Organizr app.

The nginx config for this is as follows:

Code: Select all

##RADARR
#
location /radarr {
auth_request /auth-0;
proxy_pass http://192.168.1.200:7878/radarr;
include /config/nginx/proxy.conf;
But according to a few sources, in order to allow apps like NZB360 to auth without logging into Organizr, you simply turn off the auth request for the API directory as follows:

Code: Select all

# RADARR CONTAINER API
location /radarr/api {
auth_request off;
proxy_pass http://192.168.1.200:7878/radarr/api;
include /config/nginx/proxy.conf;
And this does work....mostly. I do get access to everything (it seems) but none of the posters/artwork comes through.

It was suggested that I also add /radarr/MediaCover with the auth_request off, but this did not make a difference.

Any suggestions on how I can get this to work without falling back on something like basic auth/.htaccess?

Thank you!
cron