Page 1 of 2

Deluge / reverse proxy woes

Posted: Mon Mar 05, 2018 1:24 pm
by pyrhic
Hi all,

Just discovered this app - amazing! If I can get everything working through this one app I'll be delighted :)

So far, I've set up Radarr and Sonarr without issue, but Deluge isn't working for some reason. I've got a nginx reverse proxy setup handling all three.

I don't really know what to ask as I'm fairly sure I've filled in the options that are there right:

* Deluge is selected as the torrent client
* Primary connection address is formatted as https://<server username>:<password>@<dynamic ip address>/deluge (I've tried both http and https incidentally)
* Deluge web password is filled in and definitely correct

Are there any other known gotchas with Deluge / nginx reverse proxies / the combination thereof I may be overlooking?

All suggestions welcome - thanks!

EDIT: something else I maybe should mention is that I currently use Transdroid to manage Deluge from my phone, and I have indeed been able to get that to work with the reverse proxy setup - so I don't *think* there's anything fundamentally wrong with the setup in that respect.

Re: Deluge / reverse proxy woes

Posted: Mon Mar 05, 2018 3:08 pm
by Kev
There aren't any known issues there. Do you have HTTP Auth AND a Deluge pass? You should be using the user/pass option below the primary connection string for the username and password instead of the user:pass@host format.

Re: Deluge / reverse proxy woes

Posted: Mon Mar 05, 2018 3:53 pm
by pyrhic
Hi Kev,

Thanks for the reply. I do indeed - http auth for the server, and then additional web password auth to login to Deluge.

To confirm, when Deluge is the selected client, the option below "primary connection address" changes to not applicable, so I don't think I can put the username/pass anywhere other than the primary connection string.

Re: Deluge / reverse proxy woes

Posted: Mon Mar 05, 2018 6:19 pm
by Kev
You definitely need the Deluge pass in the pass box, just no username.

Re: Deluge / reverse proxy woes

Posted: Mon Mar 05, 2018 8:43 pm
by pyrhic
Hmm. I tried it without username and password and no dice.

I've been able to get it working on local network using the internal IP and port, so the issue is definitely around the reverse proxy - I just don't know what it is; like I said, it works with Transdroid, and the only difference I can see is that Transdroid asks you to specify /deluge in a separate 'folder' option rather than directly in the address (you also have to specify port 443 or it tries to add port 8112 to the end - specifying port in NZB360 has no effect.)

Anything else I should check out?

Re: Deluge / reverse proxy woes

Posted: Mon Mar 05, 2018 10:31 pm
by Kev
Try not adding the /deluge

Re: Deluge / reverse proxy woes

Posted: Mon Mar 05, 2018 10:50 pm
by pyrhic
Didn't work :/ I've honestly tried every permutation of http, https, username, no username, /deluge, port specified etc I can think of. Very odd.

At least local works I guess!

Re: Deluge / reverse proxy woes

Posted: Tue Mar 06, 2018 12:26 am
by Kev
If you PM me your connection details, I'll figure it out.

Sent from my SM-G965F using Tapatalk


Re: Deluge / reverse proxy woes

Posted: Tue Mar 06, 2018 11:28 am
by pyrhic
Hi Kev,

Thanks, I appreciate it. What connection info do you need exactly?

Re: Deluge / reverse proxy woes

Posted: Tue Mar 06, 2018 1:50 pm
by Kev
Mainly your primary connection string and user/passes. Please change your username/password though so I don't have your normal one.

Sent from my SM-G965F using Tapatalk