Page 2 of 2

Re: Deluge / reverse proxy woes

Posted: Wed Mar 07, 2018 4:42 pm
by mediacowboy
Something you may try is log in to deluge from your web browser and then try again in the app

Re: Deluge / reverse proxy woes

Posted: Wed Mar 14, 2018 7:00 pm
by mitsuhide
mediacowboy hits on a good point. Depending on how your Deluge is set up, it won't be 'active' upon startup unless you log in once and start the daemon. At least this is how it operates with my docker setup. I ended up adding a line to the core.conf to automatically connect to the default daemon on startup which fixed this.

Otherwise, I have it working fine via reverse proxy.

My primary connection address is set as such:

http://user:password@mydomain.com/deluge

deluge web password is set appropriately.

going to https://mydomain.com/deluge works fine after it presents me with the basic auth request.

Re: Deluge / reverse proxy woes

Posted: Fri Mar 16, 2018 12:13 am
by mediacowboy
mitsuhide wrote:mediacowboy hits on a good point. Depending on how your Deluge is set up, it won't be 'active' upon startup unless you log in once and start the daemon. At least this is how it operates with my docker setup. I ended up adding a line to the core.conf to automatically connect to the default daemon on startup which fixed this.

Otherwise, I have it working fine via reverse proxy.

My primary connection address is set as such:

http://user:password@mydomain.com/deluge

deluge web password is set appropriately.

going to https://mydomain.com/deluge works fine after it presents me with the basic auth request.
What was the line you added? As I need to do this to mine.

Re: Deluge / reverse proxy woes

Posted: Sat Mar 17, 2018 7:06 am
by mitsuhide
Sorry it was web.conf and for my setup the line was:

"default_daemon": "127.0.0.1:58846",

I run it in a docker container.

Re: Deluge / reverse proxy woes

Posted: Fri Mar 30, 2018 6:46 pm
by pyrhic
Hi Mitsuhide,

Thanks for the suggestion! Just FYI, while setting default daemon as you have seems to work in some cases, I was reading a post only the other night from the developer who said default daemon should actually be set to the alphanumeric string you'll find in the hostlist.conf.1.2 file in your deluge config folder. This is how mine is set up and it does indeed work, but y'know, if it's working for you, maybe just leave well alone (or at least back up web.conf first).

As to my own problem, it has magically resolved itself! Except possibly not magically; I've also been having trouble getting Headphones to send torrents to Deluge - after a bit of reading (and don't ask me for the post trail, I've lost it) I decided to try deleting my auth file in the deluge folder (the next time you start deluged, a new auth file is generated.) It didn't solve my Headphones problem, but it may just have been the thing that solved my Nzb360 woes. At least it's fixed I guess!

Thanks for your help all :)

Re: Deluge / reverse proxy woes

Posted: Tue Jun 05, 2018 2:40 am
by SgtBatten
I'll try that when I get home.

Also having this issue.

Deluge through nzb360 works fine on LAN but cant get it to connect whn on WAN.

Deluge itself is accessible from outside my network