#33
Hi i have found the problem with this bug, it is a api change dated the 26th july from using "Qualities" to "Profiles" please see attacthed photo.
Image here is what the folder is in the master branch of nzbdrone Image and this one is from the develop branch Image so the api is now looking for profiles instead of Qualities.

here is the commit for it https://github.com/NzbDrone/NzbDrone/co ... 1fbf43a535

i found this problem by installing a clean version of nzbdrone on a different machine and installing the develop build updates one by one, from the latest master/stable build and testing it with nzb360 till it couldn't find the Qualities anymore.

Hope this helps

Regards

Scalda
Last edited by scalda on Sun Aug 10, 2014 4:49 pm, edited 1 time in total.
#34
Great find @scalda. Hopefully @Kev can put out a quick fix for those of us using the develop branch, as long as it doesn't break it for those on the master branch.

Edited
Last edited by CBers on Sun Aug 10, 2014 4:55 pm, edited 1 time in total.
#35
i think you mean can, and yes that's true about it not breaking the master branch which i think it would unless @kev can make it look for both, at least until the next stable release is out.
#36
Great work, Scalda! My official stance is I do not support the development branch (of any service), since it just complicates and forks the development of the app. I already have to juggle the changes between 7 different services, and adding in separate branches would just make things unsupportable.

That being said, if I can figure out a way to get this in without affecting the master, I'll do it =)
#37
I raised a question on the NzbFroums about when the change would be released to master, but according to markus101, he made a fix yesterday.

I have tested it, but although I don't get the "Retrieving quality profiles, try again in a few minutes" message any more, I do get this:
Image Markus101 believes this is an NzbDrone issue though.

Full thread here.
#39
CBers wrote:I raised a question on the NzbFroums about when the change would be released to master, but according to markus101, he made a fix yesterday.

I have tested it, but although I don't get the "Retrieving quality profiles, try again in a few minutes" message any more, I do get this:
Image Markus101 believes this is an NzbDrone issue though.

Full thread here.
I'm also unable to add shows and get the same error message.