#1
(Sorry if this isn't the correct forum.)

I have started getting the following error every time I try and use any CouchPotato functionality:

ERROR: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was BEGIN_ARRAY at line 1 column 24

This error has only started happening in the last couple of days. My CP installation on Linux Mint 16 appears to be up to date (version 24028340 - git, master), and NZB 360 was updated to the latest version in the last couple of days.

I've restarted everything a couple of times, but it's not made a difference.

Thanks,

Chris
#2
- Try searching for Wanted items: HOST:5050/api/<APIKEY>/movie.searcher.full_search
- Try removing recently added movies, and re-add them again.
- Check logs for any errors. If there are any, google them before you post an issue here. Additionally you can enable debug logging for extra details.
- Check if all your settings - hosts, ports, apikeys, credentials, etc. - are all correct. Re-enter them to make sure. (when pasting keys, sometimes a whitespace get's pasted with, make sure to remove it)

You can try the above and see if the error message still appears.
#3
Thanks for the suggestions.

Running "...movie.searcher.full_search" returned {"success": true}

I then deleted all movies in my Wanted list, but refreshing on any of the tabs (Wanted, Available, Manage, etc) still shows an empty list and the red error message.

I checked the debug log in CouchPotato but hitting refresh in NZB 360 does not add anything to the CP log.

I manually re-entered everything in NZB 360 for CP, and tried the host's LAN IP instead of the usual hostname I use. API key is 100% correct. Still nothing though.

I plugged my phone into my laptop and have found some things that may or may not be related in logcat:

(I've removed the date, time and "W/System.err(2312):" from the start of each line.)

Code: Select all

java.io.FileNotFoundException: /data/data/com.kevinforeman.sabconnect/files/indexers.bin: open failed: ENOENT (No such file or directory)
	at libcore.io.IoBridge.open(IoBridge.java:409)
	at java.io.FileInputStream.<init>(FileInputStream.java:78)
	at android.app.ContextImpl.openFileInput(ContextImpl.java:838)
	at android.content.ContextWrapper.openFileInput(ContextWrapper.java:179)
	at com.kevinforeman.sabconnect.helpers.Helpers.GetIndexersFromFile(Helpers.java:514)
	at com.kevinforeman.sabconnect.SettingsLauncherView.LoadIndexerList(SettingsLauncherView.java:200)
	at com.kevinforeman.sabconnect.SettingsLauncherView.onResume(SettingsLauncherView.java:75)
	at android.app.Instrumentation.callActivityOnResume(Instrumentation.java:1192)
	at android.app.Activity.performResume(Activity.java:5310)
	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2798)
	at de.robv.android.xposed.XposedBridge.invokeOriginalMethodNative(Native Method)
	at de.robv.android.xposed.XposedBridge.handleHookedMethod(XposedBridge.java:631)
	at android.app.ActivityThread.performResumeActivity(Native Method)
	at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:2837)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1248)
	at android.os.Handler.dispatchMessage(Handler.java:102)
	at android.os.Looper.loop(Looper.java:136)
	at android.app.ActivityThread.main(ActivityThread.java:5144)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:515)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:795)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:611)
	at de.robv.android.xposed.XposedBridge.main(XposedBridge.java:132)
	at dalvik.system.NativeStart.main(Native Method)
Caused by: libcore.io.ErrnoException: open failed: ENOENT (No such file or directory)
	at libcore.io.Posix.open(Native Method)
	at libcore.io.BlockGuardOs.open(BlockGuardOs.java:110)
	at libcore.io.IoBridge.open(IoBridge.java:393)
	... 23 more
Looks like it's missing a file, maybe?

I backed up my settings, uninstalled the app, downloaded and installed a new copy from the website, then restored my settings. CP still not working, though SABnzbd+ and Sick Beard work fine.
#5
Wiped the app data and cache and tried again and CP is still not working :(

Device is Samsung Galaxy S III [GT-I9300] running CyanogenMod 11 snapshot M7 [20140609]
#6
I've had another play around, and the problem seems to only lie with NZB 360 version 8.4.x (can't remember the last digit). Uninstalling and reverting to 8.3 cures the problem, and I am able to use CP with NZB 360.
#8
Hmm weird. Are there any errors in the logs? And I mean 'any', independent from any Nzb360 activity. If there is anything corrupt in the database, it might be the cause. And is it happening on every pane?
#9
Yea, on every screen, and I dont have an old version to test it with.

Where can I find additional logs ?
Attachments
20140705205935.png
error
20140705205935.png (107.73 KiB) Viewed 4153 times
#10
Just to be sure, when you say "logs", are you referring specifically to CP logs or are there some NZB 360 logs I can find as well?

When looking at the CP logs earlier, I made sure logging was enabled, restarted CP and cleared the log. I then started NZB 360 and tried refreshing a few times, and running the renamer scan from NZB 360. Nothing I did in the app made anything appear in the CP log.
cron