#12
Great to hear! This fix was a shot in the dark, since I couldn't reproduce the issue on my side, but I am glad to hear it worked! =)
#13
Afraid to say that I still have this issue even after updating to 8.2.1.
Everything's working fine but my SABnzbd API key is still initially being sent followed by the correct SickBeard key... very strange! :?
#15
I can't see anything unusual in the logs for SABnzbd, Couch Potato or Headphones so I don't think they are affected. I just tried installing a fresh copy of SickBeard on a different machine and setup NZB360 to link to it. Exactly the same thing happens, it all seems to work but there is a warning in the logs due to the SABnzbd API being sent.
#16
I have the same issue. It happens consistently, but only started after I changed configuration of my server.

Originally I had setup NZB360 to connect directly to the Sickbeard server. It had it's own username and password, and I did not change the web root. I also had SSL enabled. NZB360 worked fine.

I then put Sickbeard (and all the other services) behind Apache. For each service I used a shared username and password using HTTP auth. I put each service behind a reverse proxy and configured the base URLs for each. I also have Apache using the same SSL certificate the services were using. Sickbeard works fine through a web browser, but NZB360 seems to use SABNZBD's API key to connect (at least that's what the Sickbeard logs state). SABNZBD and Headphones work fine with this setup, but Sickbeard doesn't (neither does Couchpotato, but that's a different issue).

I've tried it with HTTP auth off and it does the same thing. Therefore I believe the problem might be in using a reverse proxy. I currently have /tv specified for the port in NZB360. This is also the web root for Sickbeard.

If you'd like access to my system or for me to test any troubleshooting steps just let me know.

NZB360: 8.3.1
Sickbeard: alpha (development) -- git : f7e20ec04fa31ddd2c8c1808b0ea545376e965cd
#17
Update! :)

I still get this error in NZB360 8.4.3. To recap my setup:
  • Apache serves as a proxy/reverse proxy for Sickbeard
  • Authentication is handled by Apache and not Sickbeard
  • HTTPS is used
I stumbled across what causes the wrong API key to be used (according to Sickbeard). My reverse proxy setup puts Sickbeard behind the /tv URL. In NZB360, if I specify the Port as /tv it will not connect to Sickbeard. Sickbeard will show a log that the wrong API key is used (in this case, it is consistently my SABNZBD API key).

However, if I specify the Port as 443/tv, everything works properly.

In other words, if I don't specify a port NZB360 is able to determine and use the correct port to connect to Sickbeard, but it uses the wrong key.
#18
cyberdelic wrote:Update! :)

I still get this error in NZB360 8.4.3. To recap my setup:
  • Apache serves as a proxy/reverse proxy for Sickbeard
  • Authentication is handled by Apache and not Sickbeard
  • HTTPS is used
I stumbled across what causes the wrong API key to be used (according to Sickbeard). My reverse proxy setup puts Sickbeard behind the /tv URL. In NZB360, if I specify the Port as /tv it will not connect to Sickbeard. Sickbeard will show a log that the wrong API key is used (in this case, it is consistently my SABNZBD API key).

However, if I specify the Port as 443/tv, everything works properly.

In other words, if I don't specify a port NZB360 is able to determine and use the correct port to connect to Sickbeard, but it uses the wrong key.
Fantastic investigative work! I will look into the code and see why this may happen. Does this only happen with SickBeard?

Thank you very much for the effort here. We'll get to the bottom of this!
#19
I also have SABNZBD, CouchPotato, and Headphones setup very similarly. SABNZBD and Headphones work fine without a port specified.

CouchPotato, however, will freak out NZB360 when I try to reach the CouchPotato activity. NZB360 doesn't crash, but I do get returned to the home screen with a popup that reads "Your CouchPotato settings are invalid. Please check settings." If I try to switch back to NZB360 it simply repeats returning to the home screen and the message. I have to use a task manager to exit NZB360 and then open it back up (it starts with the SABNZBD activity).

Luckily, this only happens when a port isn't specified. If I use 443/movies everything works fine.