Page 1 of 2

Doesn't Connect with qBittorrent 4.2.0

Posted: Wed Dec 04, 2019 11:40 am
by fghafoor
Thanks for the awesome product!

I upgaded qBitorrent to 4.2.0 and the app couldn't connect with it anymore, so just to be sure I reinstalled 4.1.9.1 and it connected again, same exact settings. The new version does have major updates with the WEBUI so would be cool if you can check this when you get a chance.

https://www.qbittorrent.org/news.php

Re: Doesn't Connect with qBittorrent 4.2.0

Posted: Wed Dec 04, 2019 4:40 pm
by crafty35a
The qBittorrent webUI API changed to v2 with this latest release. Sonarr and Radarr have both been updated to work, e.g. https://github.com/Radarr/Radarr/pull/3356

It would be great to get a fix for this in NZB360!

Re: Doesn't Connect with qBittorrent 4.2.0

Posted: Thu Dec 05, 2019 6:42 am
by Kev
Will fix this weekend.

Re: Doesn't Connect with qBittorrent 4.2.0

Posted: Thu Dec 05, 2019 1:26 pm
by crafty35a
Excellent - thanks!

Re: Doesn't Connect with qBittorrent 4.2.0

Posted: Mon Dec 09, 2019 1:23 am
by Kev
Fixed in v13.2.2!

Re: Doesn't Connect with qBittorrent 4.2.0

Posted: Tue Dec 10, 2019 3:33 pm
by HCuser
I am able to successfully connect to qBittorrent 4.2.0 in the settings of NZB360, but in the actual tabs it just says "could not connect to Torrent Client". I am also able to connect via webui, sonarr, radarr, lidarr. Are that any settings specific to this update that need to be changed on my end? I've tried rebooting the server, I've tried clearing the app cache. I don't think it's a password issue since it is saying connected in the settings. Thank you for the help.

edit: I'm on app version 13.2.2

Re: Doesn't Connect with qBittorrent 4.2.0

Posted: Tue Dec 10, 2019 3:46 pm
by Kev
If it connects via settings but not the main screen, it's usually a parsing issue with one of your items. The only real way for me to fix is to try and connect to your qBit instance. Would you mind sending me your connection details via a PM so I can debug?

Re: Doesn't Connect with qBittorrent 4.2.0

Posted: Tue Dec 10, 2019 4:22 pm
by HCuser
With all due respect (genuinely), is there something I could try looking for on my end that would not require me giving you access to my system?

Edit: After digging around, I did find that I was able to set my throttle from within NZB360, even though the screen says it could not connect. I never need to change my throttle remotely, but it thought it was weird that I could do that.

Re: Doesn't Connect with qBittorrent 4.2.0

Posted: Tue Dec 10, 2019 5:01 pm
by Kev
Haha, no worries, completely understandable. Yeah, throttling works because it actually is connected, it just can't parse one of your torrents for some reason. Without knowing that exact item, there isn't much I can do :(

Re: Doesn't Connect with qBittorrent 4.2.0

Posted: Tue Dec 10, 2019 5:19 pm
by HCuser
Bummer. I've got 2200+ Linux ISOs seeding... Hopefully as things cycle out it will start showing up again. Thanks for the updates.