Page 7 of 8

Re: [nzbdrone] can't connect when using reverse proxy and ht

Posted: Sat Oct 17, 2015 11:25 am
by pdf
Bump? It's been a long time since I've been able to use NZB360, I'd really like to be able to use it again.

Re: [nzbdrone] can't connect when using reverse proxy and ht

Posted: Sat Jan 02, 2016 4:47 pm
by colejones
pdf wrote:Just realized I can check the other services without having them installed by seeing which vhost they hit. The final tally for SNI support by service is:

[*] NZBGet: false
[*] SABnzbd: false
[*] Sonarr: false
[*] SickBeard: true
[*] CouchPotato: true
[*] Headphones: false

While cleaning this stuff up, I'd also like to request that any service that supports auth should use a dedicated user/password field, so that the password is not exposed in the UI.
PhAzE wrote:Awesome work on drone! I use a reverse proxy with https (SSL) but drone itself has https off. I get an error that this app can't connect to nzbdrone through https when expecting http. Any ideas?

Hey Kev, any update on this. Is this live in the latest version. I look forward to this and many thanks to you in advance :D

Re: [nzbdrone] can't connect when using reverse proxy and ht

Posted: Sat Jan 02, 2016 7:39 pm
by pdf
colejones wrote:Hey Kev, any update on this. Is this live in the latest version. I look forward to this and many thanks to you in advance :D
It's not - there's been no update to NZB360 since June unfortunately - Kev mentioned he was hoping to have some time on the holidays to work on the project, but I'm not sure if that's turned out to be the case.

Re: [nzbdrone] can't connect when using reverse proxy and ht

Posted: Thu Jan 07, 2016 2:46 am
by CHBMB
I'm using a https reverse proxy with sonarr using http with no problems...

Re: [nzbdrone] can't connect when using reverse proxy and ht

Posted: Thu Jan 07, 2016 3:01 am
by pdf
CHBMB wrote:I'm using a https reverse proxy with sonarr using http with no problems...
Are you using SNI? (hint: you're not if this is working)

Re: [nzbdrone] can't connect when using reverse proxy and ht

Posted: Thu Mar 31, 2016 8:05 am
by pdf
Kev wrote:I was going to port everything over to OkHttp, but the current library I am using is going to support SNI soon.
Good to see some updates rolling out for nzb360, do you know if this ever happened? Could we possibly have SNI support now just by updating the lib?

Re: [nzbdrone] can't connect when using reverse proxy and ht

Posted: Wed May 04, 2016 8:33 am
by KarthVader
The last update indicated that this was fixed, unfortunately at least for me it is still not working. On the other hand the app NZBManager works with my current reverse proxy set up.

Kev I am willing to send you domain/port/api if you have the time to help troubleshoot.

Re: [nzbdrone] can't connect when using reverse proxy and ht

Posted: Wed May 04, 2016 2:58 pm
by Kev
KarthVader wrote:The last update indicated that this was fixed, unfortunately at least for me it is still not working. On the other hand the app NZBManager works with my current reverse proxy set up.

Kev I am willing to send you domain/port/api if you have the time to help troubleshoot.
Are you using SNI? That still is not fixed. Sending me your connection details will be helpful to troubleshoot either way though. Thanks!

Re: [nzbdrone] can't connect when using reverse proxy and ht

Posted: Wed May 04, 2016 4:24 pm
by KarthVader
I've PMd Kev, Summary:
If I understand correctly I am using SNI as I have a single IP with several subdomains each with their own SSL certificate.

Re: [nzbdrone] can't connect when using reverse proxy and ht

Posted: Thu May 05, 2016 6:54 pm
by LuisFlores3
I can say that i have been using NZB360 with SNI and all services work just fine.
My sonarr config is here if anyone is interested.