#31
parr wrote:Hello,

I can't get the banner art to work with Nzbdrone and Nzb360 v8.0.3. I have SSL enabled for local access (on port 9898), although I could only get it to work with my reverse proxy (NginX) when pointing it at the non-SSL local port (8989). I have auth enabled and the user/pass set in NZB360 in the dedicated user/pass fields.

Regardless of whether I'm local or remote, I can't get the banner art to load. The artwork for 'Airing' & 'Missed' does load though in both instances.

Thanks in advance. And well done on creating the app, its great.
Do you have any basic HTTP auth outside of Drone?
#32
Having an issue myself.

Running Apache with reverse proxy setup to my local (http on 8989 standard) instance of Nzbdrone. I have NZB360 configured to point to my server, port 443/nzbdronn.

When I try to connect with auth required and put my username/password in the fields, I get a blank error (Just says "Error: .") If I disable authentication (I dont want to) though, NZB360 is able to talk fine.

I'm using NZB360 Version 8.1
#36
I'm having problems with Apache's basic HTTP auth and NZBDrone's reverse proxy too, but unfortunately there are no easy to fix trailing slashes causing my issues that I can see :(

Whenever I try to connect to NzbDrone, I get a red pop up with the standard 401 Unauthorized error, saying I either supplied the wrong credentials or NZB 360 didn't supply them in the right way. I've triple checked everything I can and it all looks fine and I'm at a total loss for what's wrong.

The funny thing is CouchPotato works perfectly fine with the same credentials and setup. Looking in the Apache logs, all the requests to CouchPotato contain the username whereas the requests to NzbDrone don't, so it's making me think there's some problem in how the auth credentials are supplied. I'm running Apache 2.4.7 and using NZB 360 8.1, if that makes any difference.
#37
Kev wrote:Well, the Drone guys set up the API key in a weird way in that it gives you access to show info, but not banner art. So if you set up auth in Drone, nzb360 cannot get access to it without authenticating with Drone first. So if you can get shows and not banner art, it's most likely a problem with the auth portion. I did have a bug in v8.0.2 with auth, but that was resolved in v8.0.3.

The key thing to note is, the auth must be added to the dedicated User/Pass fields, not the IP address auth like in other services.
Ok, i'll have him double check (and reset) his username and password in both applications and see if that resolves it.
#38
punchsideiron wrote:I'm having problems with Apache's basic HTTP auth and NZBDrone's reverse proxy too, but unfortunately there are no easy to fix trailing slashes causing my issues that I can see :(

Whenever I try to connect to NzbDrone, I get a red pop up with the standard 401 Unauthorized error, saying I either supplied the wrong credentials or NZB 360 didn't supply them in the right way. I've triple checked everything I can and it all looks fine and I'm at a total loss for what's wrong.

The funny thing is CouchPotato works perfectly fine with the same credentials and setup. Looking in the Apache logs, all the requests to CouchPotato contain the username whereas the requests to NzbDrone don't, so it's making me think there's some problem in how the auth credentials are supplied. I'm running Apache 2.4.7 and using NZB 360 8.1, if that makes any difference.
Where did you add your auth credentials to?

If you're using NzbDrone auth, enter those details into the dedicated user/pass fields.

If you're using basic HTTP auth at your server, do the user:pass@host syntax in the IP/Host field.

At this time, you cannot use both HTTP auth and NzbDrone auth in nzb360.
#39
Kev wrote:Where did you add your auth credentials to?

If you're using NzbDrone auth, enter those details into the dedicated user/pass fields.

If you're using basic HTTP auth at your server, do the user:pass@host syntax in the IP/Host field.

At this time, you cannot use both HTTP auth and NzbDrone auth in nzb360.
I'm only using basic HTTP auth; NzbDrone is not setup to require authentication. The user/pass fields are empty, and I have the user:pass@host syntax setup in the IP/Host field. I've even tried copying and pasting the user:pass@host value from the CouchPotato service settings (since CP works fine and uses the same auth settings in Apache) on the off chance I was making some sort of typo, but no dice.
#40
My friends problem turned out to be an invalid password so this is now working. I'd also like to mention that nzbdrone just added the ability to grab images through api as of today ;)