#5
Hey Kev, wondering if you can help me out on this.

I now have Deluge behind a NGINX reverse proxy with HTTP AUTH. I'm able to get Sonarr/Radarr/NZBget all working fine following this scheme below...but Deluge doesn't work. I think the problem is just with the way your app takes the URL input for Deluge. In other words, if you would allow for HTTP username password like you do with NZBget, I'm sure this would work.

For Sonarr/Radarr:
https://username:password@service.domain/service

But for NZBget, this works:
https://NZBget.domain/NZBget
Then I put my http auth username password in the fields provided.

And in case your wondering, yes, I'm using both a subdomain and a subdirectory for each of my services. This allows me to have Server Auth (for Organize) and HTTP AUTH for mobile apps like NZB360.

Maybe I just need to remove the NGINX server side HTTP AUTH from Deluge and just use the Deluge native password option....

Update: Nevermind. Got it working how I want.
cron