Reverse Proxy- Can't connect!

Having trouble setting everything up? No worries, we'll help.

Re: Reverse Proxy- Can't connect!

Postby AdmirableAvalanche » Sat Jul 08, 2017 3:45 pm

well any web domain is port 80 by default, without even having to type anything. For instance, if you type google.com:80 in your web browser, you'll notice that it just automatically redirects to google.com. Same holds true for 443 except for https (not http).

When the client is asking for a port, it's not thinking about 80/443 (it knows the web domain would handle something like that), it's wondering what external port you've specified in sabnzbd, which--since you're doing reverse proxy--is none.

I would:

1. Uncheck SSL in the client, since it would be looking for sabznbd's certs (which it wouldn't find--you're doing SSL through your web server, not sabnzbd)

2. double check your web server config file that you're /sabnzbd text is the same in the NZB360 client and the config file. For instance, one might be "/sabnzbd" while the other is "/sabnzbd/"

Also, if you haven't done so already, look in to how to have your web server auto-redirect http traffic to https. That way you'd never have to worry about specifying 80/443 ports to begin with: https://www.rosehosting.com/blog/how-to ... nd-apache/
AdmirableAvalanche
 
Posts: 7
Joined: Wed Jul 05, 2017 1:36 pm

Re: Reverse Proxy- Can't connect!

Postby antigravity83 » Sat Jul 08, 2017 9:33 pm

Ok thanks, I'll give it another shot and report back, thanks for the detailed explanation!
antigravity83
 
Posts: 7
Joined: Sun Jul 02, 2017 5:26 am

Previous

Return to Support