Everything but Couchpotato works

Having trouble setting everything up? No worries, we'll help.

Everything but Couchpotato works

Postby mkyb14 » Sat Dec 26, 2015 7:34 pm

Great App.

Everything works but couch potato, and I'm not sure why. linked is a screenshot of the error at the bottom.

https://drive.google.com/file/d/0B15p4p ... sp=sharing
mkyb14
 
Posts: 1
Joined: Mon Dec 21, 2015 2:07 am

Re: Everything but Couchpotato works

Postby jlfrank83 » Mon Dec 28, 2015 7:42 pm

Getting the same here, just started a few days ago. This isn't happening when I use the Couchpotato web interface and there's nothing in the CP logs either. Seems to be isolated to NZB360.

Dev, please feel free to contact me by email. I'm a software analyst by trade and happy to help however I can.
jlfrank83
 
Posts: 1
Joined: Mon Dec 28, 2015 7:39 pm

Re: Everything but Couchpotato works

Postby skorov » Thu Dec 31, 2015 7:41 am

I have this same issue. Also started a few days ago.

It seems like something has changed, either in Couchpotato or in IMDB (and the data that CP stores).

I'm also an ex software dev and happy to help. :-)

EDIT: I *may* have figured it out. Seems like CP changed the JSON API response in the rating.imdb section.

Old syntax:
Code: Select all
"imdb" : [7.9, 304909]


New syntax:
Code: Select all
"imdb" : {
   "0" : 5.5
}


It has only done this for new additions to the database. Old movies still seem to retain the old syntax.

Can anyone confirm this?
skorov
 
Posts: 2
Joined: Thu Dec 31, 2015 7:34 am

Re: Everything but Couchpotato works

Postby f3bruary » Thu Dec 31, 2015 9:26 am

skorov wrote:I have this same issue. Also started a few days ago.

It seems like something has changed, either in Couchpotato or in IMDB (and the data that CP stores).

I'm also an ex software dev and happy to help. :-)

EDIT: I *may* have figured it out. Seems like CP changed the JSON API response in the rating.imdb section.

Old syntax:
Code: Select all
"imdb" : [7.9, 304909]


New syntax:
Code: Select all
"imdb" : {
   "0" : 5.5
}


It has only done this for new additions to the database. Old movies still seem to retain the old syntax.

Can anyone confirm this?

I noticed this only for rating that are 0. There was a issue opened on gh and I mentioned there that it might be related. Have yet to hear from Kev or RuudBurger
-f3b
User avatar
f3bruary
 
Posts: 585
Joined: Wed Feb 26, 2014 7:12 pm
Location: /root

Re: Everything but Couchpotato works

Postby dmxs » Sat Jan 02, 2016 3:59 pm

I've been having the exact same issue for the past couple weeks.
dmxs
 
Posts: 1
Joined: Sat Jan 02, 2016 3:54 pm

Re: Everything but Couchpotato works

Postby Keelan » Sun Jan 03, 2016 1:52 am

Same issue unfortunately :(

Image
Keelan
 
Posts: 25
Joined: Sat Mar 01, 2014 3:30 am

Re: Everything but Couchpotato works

Postby tjc2005 » Wed Jan 06, 2016 7:31 am

yup, same here! Does it on NZBmanager too, so its definitely not isolated to NZB360.
tjc2005
 
Posts: 5
Joined: Fri Oct 09, 2015 12:51 am

Re: Everything but Couchpotato works

Postby HCuser » Wed Jan 06, 2016 5:31 pm

Just thought I would chime in that I have been getting the same error as well. I am on the master branch and no settings in NZB360 have been touched. it just started giving this error when a checked it a while back.
HCuser
 
Posts: 7
Joined: Sun Apr 20, 2014 4:28 pm

Re: Everything but Couchpotato works

Postby Kev » Sat Jan 09, 2016 6:26 pm

Issue has been resolved. Update coming shortly.
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1235
Joined: Mon Feb 24, 2014 2:29 am

Re: Everything but Couchpotato works

Postby skorov » Mon Jan 11, 2016 2:19 am

Kev wrote:Issue has been resolved. Update coming shortly.

Yay! Just wanted to say thanks Kev! Not just for the fix, but also for a really great app. I use it almost daily. :-)
skorov
 
Posts: 2
Joined: Thu Dec 31, 2015 7:34 am

Next

Return to Support