Couchpotato reverse proxy access?

Having trouble setting everything up? No worries, we'll help.

Couchpotato reverse proxy access?

Postby CHBMB » Mon Oct 06, 2014 3:53 pm

Hi,

Love the app and decided today to setup remote access from my WHS2011 server.

Everything up and working with NZBdrone & Sabnzbd in NZB360.

I can access my couchpotato webpage from http://myservername.homeserver.com/couchpotato but when I try and set it up in NZB360 I get an error saying

"Your couchpotato settings are invalid. Please check the settings." and then the app crashes.

I use a username and password

My settings in the app are:

IP/Host Address
LOCAL:user:pass@192.168.1.1
REMOTE:user:pass@myservername.homeserver.com

Server Port For CouchPotato
LOCAL:8083/couchpotato
REMOTE:/couchpotato

I have checked my api key and it is correct.

If I delete the remote configs then it connects fine to my local address.

I'm a bit stumped as to what I'm doing wrong and would love some help!

Thanks
CHBMB
 
Posts: 13
Joined: Mon Oct 06, 2014 3:29 pm

Re: Couchpotato reverse proxy access?

Postby lordjynx » Mon Oct 06, 2014 4:11 pm

Are you using the API to gain access as well? On my settings, I remove the user@pass:IP stuff and just authenticate via the API setting.

Is remote port 80? If so, try 80/couchpotato... shouldn't be needed but.. :)

LJ
lordjynx
 
Posts: 97
Joined: Tue Mar 25, 2014 8:11 pm

Re: Couchpotato reverse proxy access?

Postby CHBMB » Mon Oct 06, 2014 4:34 pm

I'm a little bit unsure by the API stuff. My remote port is 8083, but using chrome on my phone I can access couchpotato using http://myservername.homeserver.com/couchpotato as I have set up the reverse proxy is IIS. That brings me to a page to enter my username and password.
CHBMB
 
Posts: 13
Joined: Mon Oct 06, 2014 3:29 pm

Re: Couchpotato reverse proxy access?

Postby Ardalista » Mon Oct 06, 2014 5:59 pm

Do you have to specify remote port for sabnzbd? On my reverse proxy all external requests go to port 80 then proxy redirects traffic to different local ports
Ardalista
 
Posts: 4
Joined: Thu Apr 10, 2014 9:49 pm
Location: Depends which VPN I use

Re: Couchpotato reverse proxy access?

Postby CHBMB » Mon Oct 06, 2014 6:28 pm

No, just installed application requested routing in IIS on WHS2011 and that takes care of everything with easily addable rules.
CHBMB
 
Posts: 13
Joined: Mon Oct 06, 2014 3:29 pm

Re: Couchpotato reverse proxy access?

Postby CHBMB » Tue Oct 07, 2014 12:24 am

I've been trying all sorts of configurations to get this to work to no avail. Works fine using just the api to access but no dice with the remote access.
CHBMB
 
Posts: 13
Joined: Mon Oct 06, 2014 3:29 pm

Re: Couchpotato reverse proxy access?

Postby Kev » Tue Oct 07, 2014 12:36 am

You absolutely need to add port 80 in the your remote port line. Should fix it.
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1320
Joined: Mon Feb 24, 2014 2:29 am

Re: Couchpotato reverse proxy access?

Postby CHBMB » Tue Oct 07, 2014 10:19 am

That does mean I can connect KeV, but unfortunately I still get an error message in a red box at the bottom of the app. Sorry haven't been able to record what it said yet!
CHBMB
 
Posts: 13
Joined: Mon Oct 06, 2014 3:29 pm

Re: Couchpotato reverse proxy access?

Postby CHBMB » Tue Oct 07, 2014 4:46 pm

So now when I attempt to login the application no longer crashes.

Instead I get this error message

http://myservername.homeserver.com:80/login/?next=%2Fcouchpotato%2Fapi%2Fmy api%2Fmovie.list%2F%3F%26status%3Dactive%26limit_offset%3D1000

then

http://myservername.homeserver.com:80/login/?next=%2Fcouchpotato%2Fapi%2Fmy api%2Fdashboard.soon%2F

in a red box along the bottom of the app. (Obviously the bold I have edited out)

This happens as soon as I enter details for the remote server and whether I am actually on a local or remote connection.

EDIT: Now I've entered my home SSID, local obviously works like a charm.

I have tried using:

user:password@myservername.homeserver.com & myservername.homeserver.com

Both with
LOCAL:8083
REMOTE:80/couchpotato

Any ideas?
CHBMB
 
Posts: 13
Joined: Mon Oct 06, 2014 3:29 pm

Re: Couchpotato reverse proxy access?

Postby CHBMB » Tue Oct 07, 2014 6:34 pm

OK, sorry everyone, finally got it sorted. Stupid mistake on my part although did need the hint to put in the port number.

Will post my config later or tomorrow to help anyone else using IIS and ARR on windows.

Next step: SSL certificates. Wish me luck!
CHBMB
 
Posts: 13
Joined: Mon Oct 06, 2014 3:29 pm

Next

Return to Support