nzb360 fails on certificate auth

Having trouble setting everything up? No worries, we'll help.

nzb360 fails on certificate auth

Postby RustyBower » Wed Jul 09, 2014 7:58 pm

I have set up my cp/sb/sab to all be externally available to me using the following (nginx proxy + ssl):
https://couchpotato.domain.com
https://sickbeard.domain.com
https://sabnzbd.domain.com

These are all accessible via certificate auth (which I have on my phone, laptop, desktop, etc).

However, nzb360 isn't attempting to use a cert to handle the request to these sites, and instead fails.

nzb360 request to couchpotato:
1.2.3.4 - - [09/Jul/2014:12:49:32 -0700] "GET /api/asdfasdfasdfasdf/dashboard.soon/ HTTP/1.1" 400 252 "-" "Dalvik/1.6.0 (Linux; U; Android 4.4.4; Nexus 5 Build/KTU84P)"

copy pasting the request onto my laptop:
1.2.3.4 - - [09/Jul/2014:12:49:42 -0700] "GET /api/asdfasdfasdfasdf/dashboard.soon/ HTTP/1.1" 200 7590 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36"

Is there any way to get nzb360 to actually recognize that the site is requesting a certificate and provide one appropriately?
RustyBower
 
Posts: 3
Joined: Wed Jul 09, 2014 7:51 pm

Re: nzb360 fails on certificate auth

Postby lordjynx » Thu Jul 17, 2014 1:14 am

Silly question... Did you enable SSL in 360 for each service? It's off by default...

LJ
lordjynx
 
Posts: 97
Joined: Tue Mar 25, 2014 8:11 pm

Re: nzb360 fails on certificate auth

Postby RustyBower » Tue Jul 22, 2014 10:08 pm

Yep. The issue is NZB360 isn't prompting me to pick a certificate to auth with. If I open the site in Chrome (on Android), it prompts me.
RustyBower
 
Posts: 3
Joined: Wed Jul 09, 2014 7:51 pm

Re: nzb360 fails on certificate auth

Postby baikun » Sun Aug 03, 2014 11:49 am

I have the exact same problem. I asked this on r/usenet as well, Kev started answering but I have no news since, maybe he is on vacation, anyway certificate authentication don't seem to be supported as it is.
baikun
 
Posts: 6
Joined: Sun Aug 03, 2014 11:42 am

Re: nzb360 fails on certificate auth

Postby Kev » Sun Aug 03, 2014 6:22 pm

Hey guys, this is going to be hard to debug for me, since I don't have any certs on my setup. Would one of you be willing to set up a test environment for me to debug with?
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1346
Joined: Mon Feb 24, 2014 2:29 am

Re: nzb360 fails on certificate auth

Postby RustyBower » Mon Aug 04, 2014 4:19 am

Emailed!
RustyBower
 
Posts: 3
Joined: Wed Jul 09, 2014 7:51 pm

Re: nzb360 fails on certificate auth

Postby baikun » Mon Aug 04, 2014 10:46 am

Hi !

Sorry for being late, RustyBower might have already sent you a testing environment, if you still need something I'm ready to help ! Just let met know.
baikun
 
Posts: 6
Joined: Sun Aug 03, 2014 11:42 am

Re: nzb360 fails on certificate auth

Postby thinmintaddict » Tue Nov 04, 2014 3:28 am

Hey,

I was wondering if there has been any progress on this? Mutual Authentication is awesome, I would love to be able to use it with this app. As it is I'm having to use a VPN client for this single app.

Russ
thinmintaddict
 
Posts: 1
Joined: Mon Nov 03, 2014 2:11 pm

Re: nzb360 fails on certificate auth

Postby baikun » Sun Jun 14, 2015 12:31 am

Still no news on this one? I just can't use nzb360 outside my local network since it's not using my certificate to authenticate me.
baikun
 
Posts: 6
Joined: Sun Aug 03, 2014 11:42 am

Re: nzb360 fails on certificate auth

Postby Kev » Sun Jun 14, 2015 3:07 am

Can one of you send me (PM) your connection details?
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1346
Joined: Mon Feb 24, 2014 2:29 am

Next

Return to Support



cron