nzbdrone (local network) connection issue.

Having trouble setting everything up? No worries, we'll help.

nzbdrone (local network) connection issue.

Postby orgo185 » Thu May 15, 2014 2:36 am

I downloaded the app to try it out and (at this point I'm only talking about accessing things from within my home network and have yet to setup remote access for anything)

It connected to Sabnzbd and worked immediately.

But I'm getting an error when I try to connect to nzbdrone, even though I've verified that the information entered is 100% correct.

I see the blurb about having to run nzbdrone as administrator once in order to open the correct port for windows users, what about for someone running nzbdrone on a linux (mint) host?
orgo185
 
Posts: 4
Joined: Thu May 15, 2014 2:31 am

Re: nzbdrone (local network) connection issue.

Postby Kev » Thu May 15, 2014 3:30 am

Not sure on the linux end. Have you checked NzbDrone's logs? Are you using HTTP auth?
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1320
Joined: Mon Feb 24, 2014 2:29 am

Re: nzbdrone (local network) connection issue.

Postby orgo185 » Thu May 15, 2014 3:43 am

Kev wrote:Not sure on the linux end. Have you checked NzbDrone's logs? Are you using HTTP auth?


Yes, and its put in front of the IP in the format suggested.

There's just a red flag that says null at the bottom of the Nzbdrone screen.

I've got no problems accessing the machine running drone from anything else on my network.
orgo185
 
Posts: 4
Joined: Thu May 15, 2014 2:31 am

Re: nzbdrone (local network) connection issue.

Postby Kev » Thu May 15, 2014 3:44 am

HTTP auth through linux, and not through Drone, right?

If so, there is a bug in v8.2.1 that I am resolving in the next update with custom HTTP auth and Drone.
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1320
Joined: Mon Feb 24, 2014 2:29 am

Re: nzbdrone (local network) connection issue.

Postby orgo185 » Thu May 15, 2014 4:32 am

Kev wrote:HTTP auth through linux, and not through Drone, right?

If so, there is a bug in v8.2.1 that I am resolving in the next update with custom HTTP auth and Drone.


through drone, i have a name and password set.

The only thing enabled in Linux right now is samba.
orgo185
 
Posts: 4
Joined: Thu May 15, 2014 2:31 am

Re: nzbdrone (local network) connection issue.

Postby Kev » Thu May 15, 2014 6:19 am

Hmm, that shouldn't be an issue then. Try disabling auth to see if that works.
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1320
Joined: Mon Feb 24, 2014 2:29 am

Re: nzbdrone (local network) connection issue.

Postby orgo185 » Thu May 15, 2014 9:02 am

Kev wrote:Hmm, that shouldn't be an issue then. Try disabling auth to see if that works.


It randomly started working after a system reboot.
orgo185
 
Posts: 4
Joined: Thu May 15, 2014 2:31 am

Re: nzbdrone (local network) connection issue.

Postby Schafur » Tue Jul 22, 2014 9:59 pm

I'm getting this same error. I'm running NzbDrone in linux as root. I put in all of the info correctly (no AUTH). I get a big red "Error: Null" at the bottom of my phone (Galaxy Note III) when i open the NzbDrone page. Strange is that it gives the error and will not show any "Series" info, but it does show "Airing" info. No AUTH, no SSL.

Sorry to bump such an old thread, but I didn't think there was any reason to create the same exact one. Thanks!

EDIT: I swear to god. I've been struggling with this for 2 days - 2 minutes after I posted this it just started working. No idea why 8-)

Sweet App - Definitely going Pro
Schafur
 
Posts: 1
Joined: Tue Jul 22, 2014 9:51 pm

Re: nzbdrone (local network) connection issue.

Postby Kev » Thu Jul 24, 2014 6:15 am

Drone is definitely finicky when it comes to HTTP Auth. A restart of Drone and nzb360 is recommended if you're running into this issue.
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1320
Joined: Mon Feb 24, 2014 2:29 am

Re: nzbdrone (local network) connection issue.

Postby svdasein » Mon Jul 28, 2014 3:20 am

I'm having a similar issue here and I'm puzzled. Sadly I've not had the luck other posters have had - I've tried restarting drone and nzb360 - still getting a red bar on the bottom that says "Error: ."

I've double and triple checked the api key - it matches. I've done a traffic capture on the server for the port my drone is listening on - I can see traffic that looks encrypted which is odd as (afaict) I have encryption turned off on both ends.

My setup is pretty simple - drone is on a server on my intranet and my android connects directly to that network. I've provided nzb360 with the ip of the server. There's no auth of any kind other than the api key.

I don't seem to find anything in the logs on the drone side either.

Really puzzled - any ideas?
svdasein
 
Posts: 1
Joined: Mon Jul 28, 2014 3:09 am

Next

Return to Support