NZBGet Reverse Proxy Issue

Having trouble setting everything up? No worries, we'll help.

NZBGet Reverse Proxy Issue

Postby evandena » Thu Apr 17, 2014 6:50 pm

Hello, I'm having an issue with NZBGet and NZB360, and was hoping someone here could help me.

I'm currently running all my web services through an Nginx reverse proxy, 80 rewrite to 443.
So far, Couchpotato and NZBdrone are working, with the settings hostname:443/location. When set to 80, it appears NZB360 can't handle the redirect to 443 (not a part of this issue though).

With the settings hostname:443/nzbget, and SSL checked, NZB360 cannot connect to NZBGet. Running TCPDUMP on the reverse proxy shows no traffic attempts on 443, where as the same settings for drone/couch work.
So it appears the traffic never leaves the app.

I would love some help on this one... thanks!
evandena
 
Posts: 10
Joined: Thu Apr 17, 2014 6:42 pm

Re: NZBGet Reverse Proxy Issue

Postby evandena » Mon Apr 21, 2014 2:20 pm

After running tcpdump on a remote gatweay looking at all traffic destined for my NZBGet server, I don't see any connection attempts whilst using port/rewrite. If I remove the rewrite and switch the port, I can see connection attempts on the remote side.

Seems like a bug in the way NZB360 handles NZBGet behind a proxy. Hoping to get a reply here....
evandena
 
Posts: 10
Joined: Thu Apr 17, 2014 6:42 pm

Re: NZBGet Reverse Proxy Issue

Postby Kev » Mon Apr 21, 2014 3:21 pm

I assume you need to connect via https with that rewrite?
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1320
Joined: Mon Feb 24, 2014 2:29 am

Re: NZBGet Reverse Proxy Issue

Postby evandena » Mon Apr 21, 2014 4:16 pm

Yes, the option is checked.
evandena
 
Posts: 10
Joined: Thu Apr 17, 2014 6:42 pm

Re: NZBGet Reverse Proxy Issue

Postby Kev » Mon Apr 21, 2014 5:20 pm

Hmm. Others have successfully connected to NZbget via a rewrite/proxy. I think the only thing I can do to troubleshoot is connect directly to your NZbget instance. Would you be ok with sharing your NZBget details with me in order to debug? If so, PM me.
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1320
Joined: Mon Feb 24, 2014 2:29 am

Re: NZBGet Reverse Proxy Issue

Postby evandena » Mon Apr 21, 2014 5:26 pm

Kev wrote:Hmm. Others have successfully connected to NZbget via a rewrite/proxy. I think the only thing I can do to troubleshoot is connect directly to your NZbget instance. Would you be ok with sharing your NZBget details with me in order to debug? If so, PM me.


Yeah, no problem. I'll shoot you a PM when I get home from work.
evandena
 
Posts: 10
Joined: Thu Apr 17, 2014 6:42 pm

Re: NZBGet Reverse Proxy Issue

Postby evandena » Wed Apr 30, 2014 3:32 pm

Have you had any luck?
evandena
 
Posts: 10
Joined: Thu Apr 17, 2014 6:42 pm

Re: NZBGet Reverse Proxy Issue

Postby Kev » Thu May 01, 2014 12:10 am

Haven't had a chance to look yet. Will do tonight.
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1320
Joined: Mon Feb 24, 2014 2:29 am

Re: NZBGet Reverse Proxy Issue

Postby lordjynx » Mon Jun 30, 2014 2:22 pm

Kev,

Not to jump into this thread but I'm also getting an issue with connecting to nzbget on 360 v8.4:

WARNING Web-Server: 404 Not Found, Resource: /api?mode=queue&output=json&apikey=xxSABNZBD-API-KEYxx&start=0&output=json

The server spits that out whenever I try to connect. Looks like it's looking for a wrong url and sending the sabnzbd api key?

LJ
lordjynx
 
Posts: 97
Joined: Tue Mar 25, 2014 8:11 pm

Re: NZBGet Reverse Proxy Issue

Postby Kev » Mon Jun 30, 2014 3:31 pm

This issue slipped through the cracks. I will look into this tonight.
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1320
Joined: Mon Feb 24, 2014 2:29 am

Next

Return to Support