Tutorial: Set up remote access to NZB 360.

Having trouble setting everything up? No worries, we'll help.

Tutorial: Set up remote access to NZB 360.

Postby Kev » Fri Feb 28, 2014 4:46 am

Enabling remote access to NZB 360 is quite easy, and completely free. Follow the steps below to enable remote (3G/4G/LTE) access to NZB 360.

Step 1: Create Dynamic DNS Address
A dynamic DNS address allows you to have a URL point to your home. Every modem receives an IP address from your ISP, but that IP address may change often. A dynamic dns address allows you to access your home's IP address, even if it changes.

First, head over to http://noip.com and create an account. Once you have that setup, add a new "host."

Image

Hostname: this is what you want your no-ip.org url to look like. For example, adding "myaddress" in this field would give you a URL of "myaddress.no-ip.biz"

IP Address: Leave this blank for now.

Once those are added, click on "Create Host" at the bottom of the page.


Step 2: Add Dynamic DNS info to router
In order for your dynamic dns address to stay in sync with your IP address, it must be updated. Most modern routers have this functionality built in. Simply Google how to enable Dynamic DNS for your router model and follow the instructions.


Step 3: Enable reserved DHCP address for computer running Usenet services (SAB, CP, SB, etc)
Most of the time, a router will automatically assign a computer an IP address at random. This creates a problem in the next step, so we want to keep this computer's IP address static. You can do this in your router as well.

Simply Google how to reserve an IP address for your router model. You will need your computer's MAC address that is running the usenet services. Enter in the MAC address and specify which IP address you would like that PC to have (usually 192.168.X.X). Once you enable that in your router, restart your router and your computer.


Step 4: Forward the correct ports
By now, we have a no-ip URL, and a reserved IP address for the PC running the usenet services. Now we need some way to talk to the computer when you visit the no-ip address. Port forwarding accomplishes this.

Simply Google how to port forward for your specific router model. All you're essentially doing with port forwarding is telling your router to talk to a specific computer when a certain port is reached.

For example, SABnzbd's default port is 8085. In your router, you will want to forward port 8085 to the reserved IP address you set up for your computer in Step 3.

You can test if this is working by visiting your no-ip address and specifying a port. For example, if you forwarded port 8085 to your computer running SABnzbd correctly, then visiting http://youraddress.no-ip.org:8085 should bring you to your SABnzbd web configuration.


Step 4: Add this info into NZB 360
NZB 360 supports both local and remote addresses. You'll want to add both to make your local requests much faster and efficient.

Comma-separate your local IP address and your no-ip address in the IP/Host field in NZB 360, like so:

Image

You should then see NZB 360 recognize these addresses as local and remote.

Image

Also, make sure to add in your SSID for your local network (home) so NZB 360 knows when to use your local address.


That's it! You now have the ability to use NZB 360 both locally and remotely, anywhere in the world. :)
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1297
Joined: Mon Feb 24, 2014 2:29 am

Re: Tutorial: Set up remote access to NZB 360.

Postby naselloj » Sat May 10, 2014 1:28 pm

Hello
I'm having a problem with Tutorial: Set up remote access to NZB 360.
I have done the first part and created an account but I can't Fill in the details marked in red.
because I don't see the Image on your site so I don't know what to fill in.
Can you help please?

First, head over to http://noip.com and create an account. Once you have that setup, add a new "host."

Fill in the details marked in red.
Image
JGN naselloj@yahoo.com
naselloj
 
Posts: 1
Joined: Fri May 09, 2014 8:02 am

Re: Tutorial: Set up remote access to NZB 360.

Postby damien487 » Mon May 12, 2014 5:26 am

Hi

I'm having the same issue seeing your image.

Could you please update the thread.

Thanks, Damien
damien487
 
Posts: 1
Joined: Mon May 12, 2014 5:24 am

Re: Tutorial: Set up remote access to NZB 360.

Postby f3bruary » Mon May 12, 2014 11:33 am

The image is redundant. Just head over to noip.com, sign in if you haven't already.

Click on Hosts/Redirects.
Then 'Add a host'.
Choose a name and add the host. That's it.
-f3b
User avatar
f3bruary
 
Posts: 593
Joined: Wed Feb 26, 2014 7:12 pm
Location: /root

Re: Tutorial: Set up remote access to NZB 360.

Postby TagCdog » Fri Jun 27, 2014 3:56 am

A question for HTTP Auth stuff, what happens if the character @ is part of our password (the simple thing is to change the password I know, but...)?

Do I use quotes around the password? Can I request that they be separate user filled fields rather than this "all-in-one" method of logging in via the hostname field?

Having special characters is that extra bit of security that makes me relax a bit when hosting something like this on the open web.

Also, if I input the API key for each application, does that bypass needing to enter the user/pass?

EDIT:
Ok, it looks like you don't need to enter in your user and pass with an API key.
TagCdog
 
Posts: 1
Joined: Fri Jun 27, 2014 3:37 am

Re: Tutorial: Set up remote access to NZB 360.

Postby pbysh » Tue Sep 23, 2014 12:49 am

f3bruary wrote:The image is redundant. Just head over to noip.com, sign in if you haven't already.

Click on Hosts/Redirects.
Then 'Add a host'.
Choose a name and add the host. That's it.


My page has a lot more options, namely "Host Type" which can be DNS Host (A), DNS Host (Round Robin), DNS Alias (CNAME), Port 80 redirect, Web Redirect.

Right now I have it as DNS Host (A) and have my external IP address in the IP box, under Group I left it empty.

I have Tomato as my router firmware and under Port Forwarding I have "Both" under "Proto", "myusername.ddns.net" under "Src address", "8081" under "External Port", "8081" under "Internal Port", and "192.168.1.X" under "Int Address"

Trying to access the ddns URL with port 8081 it just hangs, though.
pbysh
 
Posts: 1
Joined: Tue Sep 23, 2014 12:43 am

Re: Tutorial: Set up remote access to NZB 360.

Postby Kev » Tue Sep 23, 2014 12:59 am

pbysh wrote:
f3bruary wrote:The image is redundant. Just head over to noip.com, sign in if you haven't already.

Click on Hosts/Redirects.
Then 'Add a host'.
Choose a name and add the host. That's it.


My page has a lot more options, namely "Host Type" which can be DNS Host (A), DNS Host (Round Robin), DNS Alias (CNAME), Port 80 redirect, Web Redirect.

Right now I have it as DNS Host (A) and have my external IP address in the IP box, under Group I left it empty.

I have Tomato as my router firmware and under Port Forwarding I have "Both" under "Proto", "myusername.ddns.net" under "Src address", "8081" under "External Port", "8081" under "Internal Port", and "192.168.1.X" under "Int Address"

Trying to access the ddns URL with port 8081 it just hangs, though.


Leave the source address blank. It won't work with dyndns addresses.
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1297
Joined: Mon Feb 24, 2014 2:29 am

Re: Tutorial: Set up remote access to NZB 360.

Postby RutgervG » Tue Oct 07, 2014 7:40 pm

Hi,

I have my ports forwarded properly (checked it pfportchecker, if sabnzbd is closed it says it is open) but i just can't get it to work. You say leave the IP address blank, but that's not possible if you choose DNS host (A). If I visit my host, myaddress.ddns.net:8080 it shows me that it is not available. Do you have any suggestions. Am I missing something crucial?
RutgervG
 
Posts: 1
Joined: Sun Oct 05, 2014 1:25 pm

Re: Tutorial: Set up remote access to NZB 360.

Postby Kev » Tue Oct 07, 2014 11:25 pm

Did you enter in your DynDNS details into your router?
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1297
Joined: Mon Feb 24, 2014 2:29 am

Re: Tutorial: Set up remote access to NZB 360.

Postby CoffeeDrinker » Thu Jun 25, 2015 11:43 am

Hi There guys, just a bump for anyone that has had trouble setting up NZB360 with NZB downloader, and didnt manage to get it connected, i had to change the details on the downloader, where instead of having the web address as localhost:8080, i changed the localhost to my IP address. This helped me big time, as then everything else fell into place. The other thing as well, i have Sophos Firewall running on my network at home, make sure you run the port forward on the router with the DynDNS (No-IP) access, and also add the ports onto your firewall for access, otherwise, you will not be able to login remotely. Keeping in mind, if you work for a company that is blocking ports, ask to get them opened, or find out what ports are open, and change that on NZB downloader, router, firewall, sickbear, sonarr and couchpotato. :)
CoffeeDrinker
 
Posts: 2
Joined: Mon Jun 22, 2015 11:22 am

Next

Return to Support



cron