Tutorial: Set up remote access to NZB 360.

Having trouble setting everything up? No worries, we'll help.

Re: Tutorial: Set up remote access to NZB 360.

Postby f3bruary » Thu Oct 08, 2015 9:59 am

namecheap
-f3b
User avatar
f3bruary
 
Posts: 602
Joined: Wed Feb 26, 2014 7:12 pm
Location: /root

Re: Tutorial: Set up remote access to NZB 360.

Postby Magic815 » Fri Oct 09, 2015 11:24 pm

So I'm unfortunately still having issues connecting remotely. What I did:

Went to no-ip and created a host. Let's call it "xyzabc.no-ip.biz". I then modified it's IP to match the one I made a DHCP reservation for in my router settings (which we'll call 192.168.1.X).

Inside my router settings I also port forwarded ports 6789 (NZBGet), 8989 (Sonarr), and 8112 (Deluge) for the IP 192.168.1.X.

Inside settings for NZBget, I put in:
IP/Host: "192.168.1.X, xyzabc.no-ip.biz"
Local SSID: <My SSID>
Port: 6789
Username/Password all entered in, etc.

Inside settings for Sonarr, I put in:
IP/Host: "192.168.1.X, xyzabc.no-ip.biz"
Local SSID: <My SSID>
Port: 8989


However, when I turn off my phone's WiFi to test out the "remote access" part, it won't connect to either Sonarr or NZBGet through NZB360. It's only working when I am connected to my WiFi.

Thoughts?
Magic815
 
Posts: 16
Joined: Wed Oct 07, 2015 6:58 pm

Re: Tutorial: Set up remote access to NZB 360.

Postby lordjynx » Sat Oct 10, 2015 1:23 am

I assume you used your public ip for no-ip? Not your private 192 address...
lordjynx
 
Posts: 97
Joined: Tue Mar 25, 2014 8:11 pm

Re: Tutorial: Set up remote access to NZB 360.

Postby Magic815 » Sat Oct 10, 2015 3:32 am

Oh, so I'm not supposed to use the DHCP reserved IP I made in my router settings? It's 192.168.1.XXX ('XXX' being actual numbers - I'm just keeping it hidden).

I'm behind a VPN, so isn't my public IP changing every time I turn on my computer?
Magic815
 
Posts: 16
Joined: Wed Oct 07, 2015 6:58 pm

Re: Tutorial: Set up remote access to NZB 360.

Postby f3bruary » Sat Oct 10, 2015 7:50 am

The no-ip domain should point to a public ip. No-ip's servers are not located in you personal network so they don't know where 192.168.1.xxx is.

If your server (where nzbget runs) is behind a vpn, then you have to use the no-ip update client to refresh the ip of the no-ip domain. If your public ip changes a lot then set the no-ip update client to refresh at a shorter interval
-f3b
User avatar
f3bruary
 
Posts: 602
Joined: Wed Feb 26, 2014 7:12 pm
Location: /root

Re: Tutorial: Set up remote access to NZB 360.

Postby Magic815 » Sun Oct 11, 2015 10:23 pm

Ah, I understand now. Got it working, thanks!
Magic815
 
Posts: 16
Joined: Wed Oct 07, 2015 6:58 pm

Re: Tutorial: Set up remote access to NZB 360.

Postby Magic815 » Tue Oct 13, 2015 1:29 pm

Aaaaaand, now it's not working again. :(

How I have it set up:

My host on no-ip is called "xyzabc.no-ip.biz". I downloaded the no-ip update client and have it up and running (it is a windows service and boots with startup).

In my router settings, I made a DHCP IP reservation for in my router settings (which we'll call 192.168.1.X). Also, I port forwarded ports 6789 (NZBGet), 8989 (Sonarr), and 8112 (Deluge) for the IP 192.168.1.X.

Inside settings for NZBget, I put in:
IP/Host: "192.168.1.X, xyzabc.no-ip.biz"
Local SSID: <My SSID>
Port: 6789
Username/Password all entered in, etc.

Inside settings for Sonarr, I put in:
IP/Host: "192.168.1.X, xyzabc.no-ip.biz"
Local SSID: <My SSID>
Port: 8989


Now I can't connect to either NZBGet or Sonarr outside of my SSID WiFi. I get an "error:null" with Sonarr, and a "not connected to NZBGet server" for NZBGet. Also, if I go to "http://xyzabc.no-ip.biz:6789" or "http://xyzabc.no-ip.biz:8989" on either my phone or home desktop browser, it won't connect to either software.
Magic815
 
Posts: 16
Joined: Wed Oct 07, 2015 6:58 pm

Re: Tutorial: Set up remote access to NZB 360.

Postby f3bruary » Tue Oct 13, 2015 1:48 pm

confirm the ports are forwarded using http://www.canyouseeme.org/ or nmap from a remote location. Also make sure nzbget/sonarr is listening on 0.0.0.0 and not something like 'localhost'
-f3b
User avatar
f3bruary
 
Posts: 602
Joined: Wed Feb 26, 2014 7:12 pm
Location: /root

Re: Tutorial: Set up remote access to NZB 360.

Postby Magic815 » Tue Oct 13, 2015 3:59 pm

I'm at work now, but will check those things when I'm home tonight.

To confirm what you're saying:
1. By remote location, you mean something like my smartphone with WiFi turned off when I'm at home tonight? On canyouseeme, it asks for the IP - do I just type in whatever current IP I have showing in the no-ip update client (meaning the IP that is currently assigned to my "xyzabc.no-ip.biz" host)? And then I just check that IP with the three ports in question (6789, 8989, 8112)?

2. To ensure that nzbget and sonarr are listening on 0.0.0.0, where do I check that? Are those in the settings in their respective WebUI's somewhere? Or is this a setting I should be checking within NZB360?
Magic815
 
Posts: 16
Joined: Wed Oct 07, 2015 6:58 pm

Re: Tutorial: Set up remote access to NZB 360.

Postby f3bruary » Tue Oct 13, 2015 6:47 pm

Magic815 wrote:I'm at work now, but will check those things when I'm home tonight.

To confirm what you're saying:
1. By remote location, you mean something like my smartphone with WiFi turned off when I'm at home tonight? On canyouseeme, it asks for the IP - do I just type in whatever current IP I have showing in the no-ip update client (meaning the IP that is currently assigned to my "xyzabc.no-ip.biz" host)? And then I just check that IP with the three ports in question (6789, 8989, 8112)?

2. To ensure that nzbget and sonarr are listening on 0.0.0.0, where do I check that? Are those in the settings in their respective WebUI's somewhere? Or is this a setting I should be checking within NZB360?


1. Yes, something that's not connected to your LAN. Your phone on 3g/4g will do. The ip has to be the current public IP address that's assigned to you server. I think it also works if you just use the no-ip.biz domain name too. And then check those ports, yeah.

2. In sonarr go to settings > General, make sure the switch for advanced settings is active. Then check if BindAddress = *. In nzbget go to Settings > Security and make sure the ControlIP is set to 0.0.0.0
-f3b
User avatar
f3bruary
 
Posts: 602
Joined: Wed Feb 26, 2014 7:12 pm
Location: /root

PreviousNext

Return to Support