NGINX Reverse Proxy + SSL trouble

Having trouble setting everything up? No worries, we'll help.

NGINX Reverse Proxy + SSL trouble

Postby NyNe » Mon Oct 30, 2017 6:18 pm

So I setup NGINX to use reverse proxies for all of my tools maybe a month ago and I was able to get nzb360 to play nice with all of that fairly easily by setting my external ports to 80/sonarr and 80/radarr etc.

Today I've decided to add SSL (with LetsEncrypt) to the mix. To be clear, I had NGINX with reverse proxies and NO SSL working with nzb360 prior to today. I was able to get SSL working in my web browser, and everything seems fine, but nzb360 won't connect to NZBGet, Sonarr, or Radarr. I am also now unable to search NZBHydra (this worked until I added SSL to the mix). The only thing I changed in nzb360 settings was my ports from 80/sonarr to 443/sonarr and checked the HTTPS/SSL box (and did the same for NZBGet and Radarr). For Hydra there is no place for port so I just changed the HTTP to HTTPS in the URL.

Any idea what's going on, or how I can troubleshoot this?
NyNe
 
Posts: 2
Joined: Mon Oct 30, 2017 5:50 pm

Re: NGINX Reverse Proxy + SSL trouble

Postby NyNe » Tue Dec 05, 2017 6:45 pm

I finally found an answer to my issue here https://stackoverflow.com/questions/391 ... roid-n-7-0
Apparently there is an issue with Android 7.0 that requires nginx to be configured to use:
Code: Select all
ssl_ecdh_curve prime256v1;


This resolved all of my issues.
NyNe
 
Posts: 2
Joined: Mon Oct 30, 2017 5:50 pm


Return to Support



cron