Problems connecting to services while on external wifi

Having trouble setting everything up? No worries, we'll help.

Problems connecting to services while on external wifi

Postby brownbear1984 » Fri Nov 17, 2017 10:13 am

Hi

Since the latest update i have been having issues connecting to my services while on an external wifi network using the local/remote configuration. Please note until recently this setup has been working very reliably with no issues.
My set up is as follows:-

Sab, radarr, headphones and sonarr running in docker containers exposing their default ports.
HaProxy running on the host proxying external domains on port 80 to the internal services on their default ports as as per below examples
movie.domain.com - 192.168.0.x:7878
tv.domain.com - 192.168.0.x:8989
sab.domain.com - 192.168.0.x:8080

The app is configured with remote ports as port 80 and local ports as the application's default ports. I have also configured the SSID of all of my internal networks.

The issue I'm experiencing is that whilst on my work wifi network (or any other external wifi network for that matter) I am unable to connect to the services. clicking on view sabnzbd on web works fine and loads the webpage without issue.
If I turn wifi off and connect only on 4G i am able to connect without issue both in the app and via chrome.
Interestingly if I'm on 4G with my wifi on but not connected to a wifi network it does not connect to any services and when I "view on web" it tries to connect to the service via the internal IP.
When at home the the application works without issues.

The application version is 10.8.3
brownbear1984
 
Posts: 3
Joined: Fri Nov 17, 2017 9:56 am

Re: Problems connecting to services while on external wifi

Postby Kev » Sat Nov 18, 2017 8:15 pm

Nothing changed in that code for 10.8.3. If you tap on the menu button while in a service and click "View Radarr on Web", does it load the right address for local/remote?
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1381
Joined: Mon Feb 24, 2014 2:29 am

Re: Problems connecting to services while on external wifi

Postby brownbear1984 » Sun Nov 19, 2017 1:18 am

Same thing happens with radarr. If I'm on my work WiFi the app doesn't connect but tapping view radarr on web resolves the correct remote URL in chrome. The only way I can work around this is to remove the local config altogether and connect only via the remote URL.
brownbear1984
 
Posts: 3
Joined: Fri Nov 17, 2017 9:56 am

Re: Problems connecting to services while on external wifi

Postby Kev » Wed Nov 22, 2017 12:38 am

Have you tried the 10.9 beta?
Developer of nzb360
User avatar
Kev
Site Admin
 
Posts: 1381
Joined: Mon Feb 24, 2014 2:29 am

Re: Problems connecting to services while on external wifi

Postby brownbear1984 » Fri Nov 24, 2017 9:30 am

Looks like the latest update has fixed it. I'll carry on testing and let you know.
brownbear1984
 
Posts: 3
Joined: Fri Nov 17, 2017 9:56 am


Return to Support